Internet Engineering Task Force - RFC 3022: Traditional IP Network Address Translator.
Internet Engineering Task Force - RFC 6598: IANA-Reserved IPv4 Prefix for Shared Address Space.
Internet Engineering Task Force - RFC 6888: Common Requirements for Carrier-Grade NATs.
Internet Society - The Internet Protocol Journal: Understanding IP Addressing and Network Architecture.